Accepted [TTT] Lua Error When Equiping a Sight to UMP

Welcome to the best TTT community on Earth
It's so awesome to see you. Sign up and join the party!
Join Now
Status
Not open for further replies.

Torbjörn

Making a chicken out of a feather!
Crescent Plus
Joined
Aug 11, 2019
Messages
406
Affected Services:
TTT​

Title:
Lua Error When Equiping a Sight to UMP​

Description:
Same as title.​

Reproduction Steps:
Equip sight to UMP​

Demonstration:
Code:
[PC] You have applied [Barska Electro Sight] onto the weapon [UMP-45].

[hub] addons/hub/lua/chub/modules/inventory/vgui/chubequipmentpreview.lua:193: attempt to index field 'Sights' (a nil value)
  1. SetItem - addons/hub/lua/chub/modules/inventory/vgui/chubequipmentpreview.lua:193
   2. unknown - addons/hub/lua/chub/modules/inventory/vgui/chubequipmentpreview.lua:156
    3. CallPanelHook - addons/crescent/lua/crescent/libs/sh_panelhook.lua:78
     4. CHUB_UpdateItem - addons/hub/lua/chub/modules/inventory/cl_inventory_ply.lua:144
      5. func - addons/hub/lua/chub/modules/inventory/cl_inventory.lua:212
       6. unknown - lua/includes/extensions/net.lua:32
 
Status
Not open for further replies.